Several different reasons can cause your camera not to power on. Please see the table below for further information and troubleshooting steps:
Issue |
Symptom Description |
Possible cause |
Things to check/solution(s) |
Other notes |
The camera not powering on |
No LED lights turning on |
Blown fuse | Check all fuses connected to the camera and replace any blown fuses. |
Powered by Cigarette Lighter: *Check the condition of the fuse of the cigarette power cable
Powered by Battery Pack (B-112/B-124/B-124X/B-130X):
Powered by Power Magic Pro: |
The camera has no response after being plugged in |
Incompatible power cable being used |
Two-wire Power Cable (CL-2P/CL-2PA) Three-wire Power Cable (CL-3P1) |
For full details on cable compatibility, please see here |
|
Only hearing a high-pitch sound from the camera |
Internal camera hardware fault | Usually high-pitch sound comes from the camera or no sound at all | If the issue persists, you may need to send it to us. Please use our Submit a request page | |
The camera not booting up correctly
|
Only GPS and/or front security LED | Potential power disruption during firmware update or camera initialization | Format the SD card and perform a manual firmware update | If the issue persists, you may need to send it to us. Please use our Submit a request page |
All or some LED lights continuously flash (more than 5 minutes) |
Error during firmware update | Format the SD card and perform a manual firmware update | If the issue persists, you may need to send it to us. Please use our Submit a request page | |
The camera continuously restarts/reboots
|
Faulty SD card | Format the SD card using the BlackVue Viewer program or try replacing the SD card | There could be bad sectors in the SD card. | |
Camera overheating |
Touch camera body; if hot, turn off the camera and let cool down for a couple of minutes. When parked, leave the car windows a few inches open to allow air circulation Make sure that "scheduled reboot" is activated in the firmware settings |
SD cards with issues can also cause rebooting and can contribute to overheating. Replace the SD card if it has issues | ||
Internal camera hardware fault | If the issue persists, you may need to send it to us. Please use our Submit a request page |
If you require any assistance, please contact our support team on 1300 967 777 Monday - Friday, 9am - 5pm (AWST) or via our Contact Us page.